GCP 13:16 PDT We have identified the root cause and applied appropriate mitigations. Our infrastructure has recovered in all regions except us-central1.
Posted Jun 12, 2025 - 20:19 UTC
Update
GCP 1241 PDT: "Our engineers have identified the root cause and have applied appropriate mitigations.
While our engineers have confirmed that the underlying dependency is recovered in all locations except us-central1, we are aware that customers are still experiencing varying degrees of impact on individual google cloud products. All the respective engineering teams are actively engaged and working on service recovery.
We do not have an ETA for full service recovery."
Posted Jun 12, 2025 - 19:44 UTC
Update
GCP: 12:30 PDT All locations except us-central1 have fully recovered. us-central1 is mostly recovered. We do not have an ETA for full recovery in us-central1.
Posted Jun 12, 2025 - 19:32 UTC
Monitoring
GCP update 12:09 PDT "Our engineers are continuing to mitigate the issue and we have confirmation that the issue is recovered in some locations."
Posted Jun 12, 2025 - 19:15 UTC
Identified
GCP is reporting 11:46 PDT "Multiple GCP products are experiencing impact due to Identity and Access Management Service Issue".