Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 27, 2026 - 06:00 UTC
Scheduled
Workspot will be performing a critical security update to the Control service infrastructure in the US region. This update is required to address a priority backend infrastructure change requested by our infrastructure provider.
Expected Impact A brief service interruption of up to 10 minutes may occur during the maintenance window.
During this period: - Administrators may be unable to sign in to the Workspot Control portal. - Users may be unable to launch new non-persistent desktop sessions. - Existing active desktop sessions will remain unaffected. - Launching persistent desktops will continue to function normally.
We apologise for any inconvenience and appreciate your patience as we complete this important security update.
Posted Aug 27, 2026 - 04:45 UTC
This scheduled maintenance affected: Workspot Control.