Workspot Watch System Reboot
Incident Report for Workspot
Resolved
This incident has been resolved.
Posted Jun 23, 2023 - 19:50 UTC
Identified
Workspot Watch may be loading slowly. Resolution in progress.

All other systems are fully operational.
Posted Jun 23, 2023 - 19:08 UTC
This incident affected: Workspot Control.