Azure East US Capacity Constraints Impacting Virtual Desktop Availability

Incident Report for Workspot

Update

Update from Microsoft:

Current Status:

Due to an increase in demand for compute resources in the region, there are capacity constraints on available compute infrastructure. This in turn resulted in service management operation and allocation failures for VM resources.
We are currently working on platform levers to restore healthy buffers in relation to capacity. We will continue to monitor the situation and supply updates accordingly.

An update will be provided on 28 May 2026, or as events warrant.
Posted May 22, 2026 - 12:45 UTC

Identified

Dear Customer,

Workspot has identified an issue affecting the availability of Virtual Desktops hosted in the Azure East US region.

Microsoft has confirmed ongoing Azure Compute capacity constraints in this region. Customers attempting to create, update, resume, scale, start, or restart Virtual Machines may experience allocation failures.

Current Impact:
- VM lifecycle operations may intermittently fail
- Running desktops are not impacted unless restarted or redeployed

How to Check if You Are Impacted:
If your subscription is affected, details will be visible under:
-->Azure Portal → Service Health → Active / Maintenance Events

Workaround:
- Redeploy the Virtual Machine from Workspot Control to help bring it online

Recommendations:
- Try a different Availability Zone within East US
- Use an alternate Azure region with lower demand

Mitigation Options:
- Disable Pause/Resume (VM runs continuously; may increase cost)
- On-demand Capacity Reservation:
https://learn.microsoft.com/azure/virtual-machines/capacity-reservation-overview
- Reserved Instances (cost benefit + prioritized capacity):
https://learn.microsoft.com/azure/cost-management-billing/reservations/save-compute-costs-reservations

Ongoing Actions:
Workspot is actively engaged with Microsoft and monitoring the situation closely.
Posted May 21, 2026 - 16:05 UTC