Service Impacted due to AWS Outage
Incident Report for Workspot
Resolved
Service is back online.
Posted over 2 years ago. Feb 28, 2017 - 10:51 PST
Identified
Engineers are working to mitigate the impact of a large-scale cloud provider outage
Posted over 2 years ago. Feb 28, 2017 - 10:42 PST