Multiple Microsoft Services are down affecting Workspot Customers
Incident Report for Workspot
Resolved
Microsoft confirmed that the issues have been mitigated.

From Microsoft:
Summary of Impact: Between 07:05 UTC and 09:45 UTC on 25 January 2023, customers experienced issues with networking connectivity, manifesting as network latency and/or timeouts when attempting to connect to Azure resources in Public Azure regions, as well as other Microsoft services including M365 and PowerBI.

Preliminary Root Cause: We determined that a change made to the Microsoft Wide Area Network (WAN) impacted connectivity between clients on the internet to Azure, as well as connectivity between services in different regions, as well as ExpressRoute connections.

Mitigation: We identified a recent change to WAN as the underlying cause and have rolled back this change. Networking telemetry shows recovery from 09:00 UTC onwards across all regions and services, with the final networking equipment recovering at 09:35 UTC. Most impacted Microsoft services automatically recovered once network connectivity was restored, and we worked to recover the remaining impacted services.

Next Steps: We will follow up in 3 days with a preliminary Post Incident Report (PIR), which will cover the initial root cause and repair items. We'll follow that up 14 days later with a final PIR where we will share a deep dive into the incident.

You can track the Post Incident Report (PIR) on the Microsoft Azure link - https://status.azure.com/

We are closing this incident from our end. Please reach out to the Workspot Support team in case you need any assistance related to Workspot Cloud Desktops.
Posted Jan 25, 2023 - 11:10 UTC
Identified
As per the latest Microsoft update on the status, they have determined the network connectivity issue is occurring with devices across the Microsoft Wide Area Network (WAN). This impacts connectivity between clients on the internet to Azure, as well as connectivity between services in data centers, as well as ExpressRoute connections. The issue is causing impact in waves, peaking approximately every 30 minutes.

They have identified a recent WAN update is the likely underlying cause, and they have taken steps to roll back this update. They are seeing signs of recovery across multiple regions and services, and are continuing to actively monitor the situation

You can monitor the status of the ongoing issue on the below Microsoft links:
- https://status.azure.com/
- https://status.office365.com/

We will keep you posted on the status periodically.
Posted Jan 25, 2023 - 09:45 UTC
Update
As per the latest update from Microsoft, starting at 07:30 UTC, they identified a networking issue impacting connectivity to Azure for a subset of users. They are actively investigating.

You can monitor the status of the ongoing issue on the below Microsoft links:
- https://status.azure.com/
- https://status.office365.com/

We will keep you posted on the status periodically.
Posted Jan 25, 2023 - 08:52 UTC
Investigating
Microsoft reported a global outage for Office 365 & Azure Portal services. Customers using Azure AD for authentication may see problems while logging into the Workspot clients or launching their desktops.

You can monitor the status of the ongoing issue on the below Microsoft links:
- https://status.azure.com/
- https://status.office365.com/

We will keep you posted on the status periodically.
Posted Jan 25, 2023 - 08:47 UTC
This incident affected: Workspot Control.