Investigating
Incident Report for Workspot
Resolved
This incident has been resolved.
Posted Oct 29, 2019 - 03:58 UTC
Investigating
Workspot has detected an incident. We are currently investigating and working to get the service up as soon as possible.
Posted Oct 29, 2019 - 03:38 UTC
This incident affected: Workspot Cloud.